Introduction

Welcome to SecureFile

SecureFile is an easy to use encryption and compression program, which is able to encrypt your personal files and sensitive data quickly, easily and securely. In addition to encryption, SecureFile creates self-decrypting exe - files which anybody with the right password / certificate can decrypt, even if SecureFile is not installed on the target system.

SecureFile incorporates public key cryptography in which two complementary keys—a key pair—are used to maintain secure communications.

It compresses and encrypts selected files and produces a self-decryption archive. The encrypted file can be decrypted simply by double clicking the archive with the given password for symmetric key mechanism and no input is necessary for certificate based decryption.


KeyFeature

Key Features

The most important features of SecureFile at a glance:

  • Strong, unbroken encryption algorithms (Blowfish)

  • Encryption option using other's certificate

  • Encrypts complete folders with all sub-folders

  • Creates self-decrypting exe-files (usable with Windows 95/98/00/NT)

  • Automatically compresses the data

  • Automatic Password Verification

  • User-friendly interface

  • Can encrypt any number of files and folders


Licence

SecureFile - License Agreement

Copyright © 1999-2001 by SecureSoft Technologies

All rights reserved.

Please read the following carefully before you use this program. If you disagree with any of the following, you are not allowed to use this program and you must remove it immediately.

SecureFile is Shareware! Shareware is software provided to computer users at no charge for a "try before you buy" evaluation period; however, payment is required if the software is used beyond its evaluation period.

The evaluation period for SecureFile is 30 days from the date of the first installation!

SecureFile is protected by international copyright laws; it is not public domain. SecureFile is offered to the user for evaluation for a limited period at no charge. You are granted a limited license to use this software for the purpose of evaluation of the software for a period not to exceed 30 days unless otherwise agreed to by SecureSoft Technologies

.

You are also granted a license to make and distribute complete and unmodified copies for the purpose of evaluation of the software by others. Permission is granted to distributors to charge a reasonable media and handling fee for diskettes or other media containing this software or for access to the software on bulletin boards or FTP sites, but only if the original distribution file remains intact and unmodified.

Use of this software beyond the 30 day evaluation period without payment of the license fee to SecureSoft Technologies is a copyright violation.

Payment of the license fee entitles a single user to use SecureFile. When you have registered and paid your license fee for this software you will receive your registration code. "Single user" means that the software is to be used only by a single individual but the software may be installed for that one individual's use on multiple computers (in the individual's office and home, for example). The software may also be installed on a single computer and be used by multiple individuals as long no two individuals can use this software at the same time. Installation with simultaneous access by multiple individuals requires a multi-user or site license. Installation on multiple PCs or a network server with simultaneous access by multiple individuals requires a multi-user license.

More details about multi-user or site licenses and other registration issues are available by e-mail from seklax@yahoo.com.

You may distribute this software to friends and colleagues, but the only file you may transfer is the original SecureFile distribution archive and not a copy of the installed software. Please encourage them to register their copy if they find that they make use of it.


Limited Warranty

SecureFile is provided "as is" without warranty of any kind, either express or implied, including, but not limited to warranties of merchantability or fitness for a particular purpose.

In no event will SecureSoft Technologies be liable for any damages, including incidental or consequential damages, arising out of the use of the program, even if advised of the possibility of such damages.

You acknowledge that you have read this license, understand it and agree to be bound by its terms as the complete and exclusive statement of the agreement between us, superseding any proposal or prior agreement, oral or written, and any other communications between us relating to the subject matter of this license.

SecureFile is shareware. You can test SecureFile for 30 days for free without any limitations. But due to the nature of registration codes you have no right to demand a refund after your registration is processed and your registration code was issued. If you have already received your registration code while your order is processed there is no way to cancel your order.


FAQ

1. What is cryptography ?

Cryptography is the science of using mathematics to encrypt and decrypt data. Cryptography enables you to store sensitive information or transmit it across insecure networks (like the Internet) so that it cannot be read by anyone except the intended recipient.

2. How does cryptography work?

A cryptographic algorithm, or cipher, is a mathematical function used in the

encryption and decryption process. A cryptographic algorithm works in

combinationwith a key—aword, number, or phrase—to encrypt the plaintext.

The same plaintext encrypts to different ciphertext with different keys. The

security of encrypted data is entirely dependent on two things: the strength of

the cryptographic algorithm and the secrecy of the key.

3. What is Public key cryptography ?

Public key cryptography is an asymmetric scheme that uses a pair of keys for

encryption: a public key, which encrypts data, and a corresponding private key

(secret key) for decryption. You publish your public key to the world while

keeping your private key secret.Anyonewith a copy of your public key can then

encrypt information that only you can read. Even people you have never met.

4. How SecureFile works ?

SecureFile combines some of the best features of both conventional ( Symmetric) and public key ( Asymmetric) cryptography.

When a user encrypts data with SecureFile, SecureFile first compresses the data.

Data compression saves modem transmission time and disk space and, more importantly, strengthens cryptographic security. Most crypt analysis techniques exploit patterns found in the plaintext to crack the cipher. Compression reduces these patterns in the plaintext, thereby greatly enhancing resistance to cryptanalysis. (Files that are too short to compress or which do not compress well are not compressed.)

In conventional cryptography, also called secret-key or symmetric-key encryption, one key is used both for encryption and decryption. The Blowfish is an example of a conventional crypto system .

In Asymmetric (Certificate based) cryptography SecureFile creates a session key, which is a one-time-only secret key. This key is a randomly generated . The session key works with a very secure, fast conventional encryption algorithm to encrypt the plaintext; the result is ciphertext. Once the data is encrypted, the session key is then encrypted to the recipient’s public key. This public key-encrypted session key is transmitted along with the ciphertext to the recipient.

Finally it creates a self-decryption archive which can be decrypted at the other end without any dependencies.


Main1

SecureFile

The user can encrypt the desired file(s) or folder(s) by locating them using the Folder/File Browse Buttons that appear just above the file/folder area.

The user has also to give the Destination path to save the encrypted archive

After selecting the Password mode , the user has to enter a password for encryption and he has to press Encrypt to start processing encryption. After successful encryption, the user will be shown an appropriate message.


Password

Password Mode

The user can encrypt the desired file(s) or folder(s) by locating them using the Folder/File Browse Buttons that appear just above the file/folder area.

The user has also to give the Destination path to save the encrypted archive

After selecting the Password mode , the user has to enter a password for encryption and he has to press Encrypt to start processing encryption. After successful encryption, the user will be shown an appropriate message.


Certificate

Certificate Mode

The user can encrypt the desired file(s) or folder(s) by locating them using the Folder/File Browse Buttons that appear just above the file/folder area.

After selecting the Certificate mode , the user has to press Encrypt to start processing encryption.

A dialog box will be displayed to select a certificate ( from ADDRESSBOOK of system store)

After successful encryption, the user will be shown an appropriate message.